N2 Web: Degraded Performance
Incident Report for Nucleus
Resolved
All issues have been remediated and things should be functioning normally now. We’ll continue to monitor the results to make sure everything’s good.
Posted Jul 19, 2023 - 03:31 UTC
Monitoring
A fix is on the way out to production, and we expect all issues to be resolved within an hour. We will monitor the results and confirm the fix is working in a future update.
Posted Jul 19, 2023 - 01:44 UTC
Identified
We're looking into degraded performance since we rolled out an update this afternoon. It is causing some loading and saving issues in the dashboard due to unprecedented server load. Sites may also be experiencing slower than normal load times.

We've identified the potential root cause, and are looking into remedies. Until resolved, you may experience poor performance in the dashboard where autosave and related in Nucleus 2 Web might not work as expected.
Posted Jul 19, 2023 - 00:53 UTC
This incident affected: Nucleus Sites, Dashboard, and API.